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Abstract: This research aims to perform the architectural drawings on Autodesk Revit
Architecture to have deep insight into the utility of Autodesk Revit. Whenever a construction
project is in the planning phase, Autodesk Revit is used to prepare 2D (floor plans in detail,
MEP systems, sections, and elevations), 3D (modeling), 4D (cost & estimation), and 5D
(project management). In the current study, a project of a multi-story building was taken as a
sample for 2D and 3D architectural drawings with render, animation, and 4D cost estimation
of openings (windows and doors). The total area of the project was 5498 square feet from
which the basement contained 3602 square feet and the ground floor covered an area of about
4118 square feet. All architectural drawings were composed of basement floor plans, ground
floor plans, and the top roof of the apartment building. All 2d drawings were prepared on
Autodesk Revit by using different commands in Autodesk Revit. In the second step, 3D
modeling in detail of the project was done with renders. Animations of the model were also
prepared. This software streamlined the design process with the help of a central 3D model,
where changes were made in one view and then they were updated across all other views as
well as on the printable sheet user interface. The cost and estimation of all windows and
doors were also prepared. The Schedule Settings window (which pops up automatically
throughout the schedule construction process) was used to set schedule properties for
preparing cost sheets. It is concluded, that Autodesk Revit is a versatile software that
develops all pre-construction documents, 2D, 3D, and 4D of any project accurately and in
less time. This makes work more efficient by eliminating the confusion of managing multiple

file versions. Revit might replace AutoCAD in the coming future.
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1. Introduction

Autodesk AutoCAD and Revit assist in building blueprints for a construction project.
AutoCAD and Revit are compatible programs despite their reputation as competitors.
AutoCAD, a drafting tool, represents details of buildings geometrically. AutoCAD was
released by Autodesk in 1982, which predates Revit. Since then, several software updates
have been included in cloud backups and mobile access. AutoCAD has dominated technical
drawing for almost 40 years. Imagine four users, viewing the same building from various
viewpoints. Construction components are only represented as geometric shapes in the
software. Due to their geometric depiction, changing one view does not affect the others. This
creates a major lag for updating the necessary changes. Thus, AutoCAD is good for 2D
drawing and precise line work but not architectural modeling. AutoCAD can create 3D
models and render them, however, they are geometric and lack element information.
Engineering teams utilizing AutoCAD must communicate well because each change requires
a manual update. Moreover, AutoCAD is neither useful in 4D (in which features of cost and
estimating are incorporated) nor in 5D (in which project management is Incorporated). On the
contrary, Autodesk Revit is useful in above above-discussed domains making it most

desirable where precise day-to-day changes are necessary. Carvalho et al [1].

Autodesk Revit is a Building Information Modeling (BIM) tool used by architects, landscape
architects, structural engineers, Mechanical electrical and plumbing engineers (MEP),
designers, and contractors. This advanced 3D model-based technique helps architectural,
engineering, and construction (AEC) professionals plan, design, build, and manage buildings
and infrastructure. Revit is also a modeling program that defines architectural components by
proposing and including technical requirements and material information. Yare, Kurexi et al
[2]. In Revit, all the design teams access the same model making it an efficient choice. The
efficiency of Revit can also be judged by a simple example if plumbing modifications overlap
with Heating ventilation and air conditioning (HVAC) it informs the designers automatically.
Revit refreshes all views, making it easy to track the changes. Revit is more advanced and
can create 3D building models, cost and estimation (4D), and project management (5D).
These include geometry, component physical properties, and interactions. Revit aids material
take-off and project bids. It can automatically generate cost schedules from technological

requirements and component costs. Revit's main limitation is the building model's rigidity,
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which applies to 2D views and drawings Carvalho, Azevedo et al [1]. Revit BIM software
can be utilized from inception through maintenance. Revit models simplify maintenance and
revisions after construction. Revit's benefits increase with the project scope Graves [3]. BIM
is used to model the structure of construction papers. Revit is a BIM tool, while AutoCAD is
merely Computer Aided Drafter. Revit federated project outputs improve project
collaboration Rao, Bhattacharya et al [4]. BIM and CAD experts in the same organization

typically collaborate on project aspects.
1.1 Problem Statement & Research Objectives

While Autodesk Revit is capable of 4D (cost and estimation) and 5D (project detail),
AutoCAD is primarily used for 2D (architectural design) and 3D (modeling). However,
AutoCAD is time-consuming as compared to Autodesk Revit. Problems with geometry and
colors may also arise while using more advanced tools and then exporting the file to an
AutoCAD format. That's why we have used Revit in this study instead of AutoCAD. The

research objectives of this study are:

e To illustrate the user interface of Autodesk Revit.

e To draw the 2d drawings of the project i.e., floor plan, sectional detail, and consist of
elevation.

e To formulate 3d modeling in Autodesk Revit.

e To estimate the cost of the openings’ doors, vents, and windows.

1.2  AutoCAD

Initially, Autodesk published its early version of AutoCAD in December 1982 after
demonstrating it at Comdex. By March 1986, AutoCAD was considered as the flagship
product of Autodesk, it was the most used CAD program. The 35" major release of
AutoCAD for Windows was done in 2021. AutoCAD for Mac was released in 2021 for the
11th year. AutoCAD natively uses "dwg" files. AutoCAD publishes CAD data in Autodesk's
"pdf" format. A compact interface with multiple toolbar and dialogue box controls maximizes
the workspace. The ribbon can be presented horizontally, vertically, or as a floating palette.
We can deliver commands like search-AutoCAD's classic drop-down menus, menu actions,
tooltips, command prompt text strings, and tags in real time. We can also use the menu
browser to find recent, open, and menu-executed documents. Likewise, pan, zoom, orbit,

rewind, and stroll from one interface, and clicking or dragging the cursor over a wedge starts
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the navigation tools. The drawing status bar accesses the commanding tools. The command to
view your cursor coordinates utilizes several display techniques to scale annotations. Access-

named views are organized by animation sequences in the drawing.
1.3 Autodesk Revit Architecture

The prime objective of developing Revit was to enable architects and other building
professionals to work on Building Information Modeling (BIM). The design and
documentation of buildings through the creation of parametric three-dimensional models that
included both geometric and non-geometric design and construction information. Autodesk
Revit is the most widely used program for dealing with the BIM. Since 2002, it has been
under the ownership of Autodesk, the firm that developed the well-known AutoCAD, and has
been progressively adopted as the BIM tool of choice by the industry. Revit, like ArchiCAD,
enables cooperation between multiple users within a single project, and it is capable of
handling all phases of the construction process Shick Alshabab, Vysotskiy et al [5]. It also
features planning tables for pulling data from various project components, as well as the
option of adding third-party add-ons and modules 2020 Although these are the most well-
known and widely used software packages, there are a variety of others, including all plans
Atreya and Agarwal [6]. While ArchiCAD and Revit are ahead of their relative competitors
in terms of implementation, there is always space for additional tools to help architects and
designers achieve their goals.

1.4 Functions of Revit

Because of AutoCAD's popularity, Autodesk Revit was intended to be a tool that could do
the same functions as AutoCAD while allowing for the direct change of object attributes
without the need for any additional programming. A parametric model of references and
"families” system and elements were used to attain this objective. The Autodesk Revit
software came in three distinct versions, each with its exclusive Architecture that may benefit
from Autodesk Revit Architecture Stine [7]. Tests and analyses were conducted using Revit
Structure to verify the stability of the structure and to design reinforcements if the Modeling
of the building's systems was done by MEP and the building's energy consumption. Autodesk
Revit is widely regarded as one of the most capable civil engineering software packages in
the market. The user can start from scratch while using Revit or access some drawings from
pre-installed families since it has a large number of features and allows one to choose a

certain "family” Pauwels, Van Deursen et al [8]. It's common for engineers to work under
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pressure, such as when they're asked to design a bathroom each item of a bathroom (such as a
sink or bathtub) manually and then insert it into the application, While there is an easy way
that the engineers may also choose from a pre-installed database. It's worth noting that Revit
also has a parametric engine, which means that any changes made will be stored and applied
to the subsequent elements. For example, on a perpendicular wall, the outside of a door frame
is a fixed dimension. There is no need to be concerned about the door relocating with the
divider Fakhrutdinov [9]. On a particular elevation, the windows or pilasters are evenly
spaced apart changing the length of the elevation does not alter this connection. As a result,
the parameter is not a numerical value but rather, a proportional one. A model element is the
actual 3D geometry of the building Fakhrutdinov [9] Datum refers to reference systems such
as grids, levels, and planes. An element that can only be seen in a certain 2D perspective is
referred to as view-specific. Some pieces can be broken down further into smaller ones. The

Revit structure is shown in Figure 1.
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Fig. 1. Revit Structure of Elemental Behavior

1.4.1 Families of Revit

Families are a group of objects that share the same parameters, as well as the same usage.
Users may access a variety of Revit families through the internet, some of which are also
preinstalled. Users cannot create a separate file for those because they are already made and

set up in programs' standard families. No changes would be made to the properties or visual
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representations while transferring system families from one project to another (e.g., floors,
walls, dimensions) Noor, Yi et al [8]. Using templates, the user may import these types of
families into a project, and modify their attributes. With the assistance of custom geometries,
the user may also define associations between things. However, they have restricted usage
and cannot be replicated as a family type to generate many kinds. There are a lot of updates
to the families that are accessible e.g., doors were updated in 2016. For example, when it
comes to wall properties, there are the Analytical properties (ones related to the material it's
made of such as heat transfer coefficient and thermal resistance), ldentity data (identifies the
object as one manufactured by one company), and URL data (identifies it as one

manufactured by a specific website).
1.4.2 3D Modeling and Rendering

In BIM, software like Revit is used for 3D building design and modeling. All parties involved
in a construction project can benefit greatly from Revit's ability to model and work on
structures or portions of buildings. When included in the BIM process, Revit modeling
simplifies the production of 3D visualizations, such as walkthroughs, detailed drawings, and
perspective views. While the standard 2D CAD programs lacked all these capabilities.
Rendering software can be used to give the model a more polished look. The scenario might
be rendered using a variety of resources, including the cloud, 3ds Max, and additional
plugins. One of the easiest ways to lower the size of your projects is to use Revit’s “Purge
Unused” which is an option under the File menu and it allows users to eliminate materials
and definitions that aren’t necessary for the project. In terms of selection, rendering plug-ins,
quality, and speed of the process are the most important considerations. For low- and mid-end
computers, cloud-based rendering engines are suggested due to their lower processing
capacity. The user's computer is a factor that limits the user to AutoCAD's built-in tool. Wu,
Liu et al [9]. The advanced form of renderings produced by Autodesk Revit is shown in Fig.
2.

Fig. 2. Revit Rendering Process
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1.4.3 Schedule and Estimation in Autodesk Revit

Information on a project's components can be tabulated and displayed using this method.
When users make changes to the model, the schedules are updated instantly. If a user
relocates a wall, for instance, the corresponding room's floor area will be recalculated.
Schedules are automatically updated if modeled building components have their attributes
modified. For instance, users might pick a door in the model and modify its manufacturer
property. The alteration to the manufacturer's property would be reflected in the door

schedule.

2 Methodology

2.1 Selection of Autodesk Revit for this Project

When compared to previous practices, new technologies have a significant effect on the
speed with which building projects are completed. Back many years, construction drawings
needed to be completed by a large number of individuals, and design information might not
be well structured at the time of the project's beginning. It was also very difficult to separate
essential information from the rest of the drawing, and the revision process took a
considerable time. Users of the Autodesk platform were able to use 2d drafting tools such as
AutoCAD, which made the process of creating building plans easier and faster. With the help
of 3D modeling, it is now possible to see a complicated project before its completion Graves
[3]. Large and complicated construction projects are required to share comprehensive
information. Unfortunately, the Autodesk AutoCAD 3D feature was unable to meet the
demand effectively. The BIM 3D modeling technique was brought into the building sector to
allow the sharing of information in 3D models easily. Compared to the prior practice, the
project delivery system and communication among all stakeholders have become more
efficient. The Autodesk platform offers construction professionals a range of software tools
to practice the BIM process in a fully 3D environment. Autodesk Revit is widely regarded as
one of the most well-known 3D BIM modeling software packages. It provides a
comprehensive environment for 3D modeling in architecture, mechanical, electrical, and
plumbing (MEP), structural design, and building construction. Project templates are provided
by Autodesk Revit software in four distinct kinds. From the construction template to the
mechanical template, each template has certain similarities as well as some differences
depending on the function it serves for the customer and the industry. Examples of 3D

environments for architectural design, such as walls and floors, may be found in the
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architecture template Bergin [10]. Meanwhile, in the structure template and construction
template, the 3D modeling of the footings, columns, and slabs is the primary focus. Autodesk
Revit, in conjunction with the project template, offered a choice of family folders that were
organized by area. Doors, windows, and column types are just a few of the single components
of a 3D model that are included inside each folder's numerous families. Autodesk Revit
creates a more user-friendly environment for its users by categorizing them into families
based on their location. It includes the 3D model component that is only utilized in that
specific area of the screen. The editing function in Autodesk Revit gave the user more control
over the final product. They can flexibly modify the geometry of families to meet the design
needs of each project. With the assistance of Autodesk Revit, a comprehensive collection of
libraries may be created for use in a variety of comparable design projects. The rendering
capabilities of the Revit program create realistic effects on 3D models based on the colors
and characteristics of the materials used in the model. When designing, it is helpful for the
designer to imagine his or her work in a rich setting before the building is completed. The
user may contribute design information at each smaller part of the model by using the 3D
representation of the model from various perspectives. The study of energy information for
buildings, on the other hand, aids in the construction of more energy-efficient buildings. It
also considers the various load scenarios that may be applied to the construction of the
building Crotty [11]. Autodesk Revit is a comprehensive package that enables civil engineers,
architects, and planners to design, evaluate, and quantify projects more simply and rapidly
than they could previously do. When using the scheduling and quantification functions, users
may estimate amounts in a short period. Because of its quantity take-off feature, Autodesk
Revit can automatically calculate quantities of different types of material families. Autodesk
Revit also works well with the company's other software products, including AutoCAD. To
be compatible with other programs such as Format, and Google Sketch-up, Revit uses DWG,
DFX, and IFC format files. The parametric modeling technique used by Revit infuses
intelligence into its 3D models. It has been used in the past, mostly by aircraft designers, to
examine numerous designs in a short period. The use of parametric modeling in Revit enables
designers to link model components with one another, allowing them to test numerous
designs in a short period. This technique in Autodesk Revit aids in the selection of more
energy-efficient and low-cost designs for construction project content 2012. For example, if
two walls in a 3D model are linked to each other, and we change the height of one wall, the

second wall will follow a pattern that is identical to the first.
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2.2 Revit Architecture New Project

When establishing a project, users may utilize a template for default parameters as a starting
point. To use a template to build a project select new from the File menu (Project), user may
do one of the following in the New Project dialogue, under the Template file: Choose a
template from the drop-down menu. Navigate to the appropriate template (an RTE file) and
click “Open”. Revit has many project templates, which may be found in the Templates folder.
Exterior wall addition Working in the 3D view, drag a selection window from right to left to
choose all walls in the view. From this user may “Select” the Modify Wall option which is a
panel for the clipboard (Copy to Clipboard). Then the user may Click the Paste drop-down
menu in the Clipboard panel, and then click (Aligned to Selected Levels). Users may adopt
the following procedure Select 02 - Entry Level from the Select Levels dialogue. Make the
following modifications to the chosen walls in the Properties panel, then click Apply: Select
Basic Wall: Generic-6 from the Type Selector “Select Up to level: 03 - Roof for Top
Constraint. Enter 0'0 for Top Offset ". Choose the walls whose bases do not touch the
foundation underneath. To pick more than one wall at a time, hold down Ctrl and click.
Select 01 - Lower Level for Base Constraint in the Properties panel, then click Apply. To
leave the Wall tool, use Esc. Select the View tab. Make a panel (Default 3D View) As Shown
in Fig. 3.

Fig. 3. Three-dimensional View & Exterior Modification

Modification of exterior walls selects the walls at the building's corners in the 3D view. Hold
“CTRL” when selecting a contained window to add walls. Select 04 - Upper Parapet from the
Top Constraint panel and click “Apply”. To deselect the walls, use “ESC”. Choose the two
walls at the building's front right corner. Set the Base Offset to 4250mm in the Properties
Palette. Double-click 01 - Lower Level in the Project Browser's Floor Plans section. Select

the Architecture tab then create a panel (Wall). Select Basic Wall: from the Type Selector.
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'Generic - 6' On the Options Bar, the user will find: Select 02 Entry Level for Height. For
Location Line, choose Wall Centreline. Remove the chain and Place it inside the walls to
construct rooms using the picture below as a guide: Create a corridor by modifying the walls
as follows: Select the Modify tab. Modify the panel (Split Element). In the preceding picture,
click on the wall at the area indicated by the small red line. Click (Trim/Extend to Corner) in
the Modify panel. As shown, trim the split wall to create a corridor. When trimming in Revit
LT, be sure to pick the parts of the components that need to be retained. Open floor plan 02 -
Entry Level. Create a similar wall by right-clicking on one of the perimeter walls. Place more

walls to build rooms using the picture below as a reference.
2.3 Doors and Windows

Revit Door and Window objects are referred to as "Hosted Components” (or "Hosted
Families" in certain cases). They are termed "Hosted" because they must have a host
component to exist. When attempting to put a Door in "free space”, an Error message
appears, indicating that it requires a Host to insert itself. When “Hosted Families” are formed
in/on their Host, they remain connected to that Host even if it moves. For example, if users
build a Door in a Wall and then decide to alter the position/rotation of the Wall element, the
Door will remain with it. To insert a Door or Window into the model, the user may go to the
Architecture menu / “Build” panel. As previously mentioned, the user needs to verify that the
model already has a Wall- so that it has something to welcome the host family. When using
the Door (or Window) tool, just hover over a piece of wall and click to install a component.
Just take note of the "No Entry" sign that appears if the pointer is not over a suitable Host (a
wall element in the case of Doors and Windows). Insert a few of the Doors onto the model
now. When the Door chooses (or Window) tool, the Options Bar will alter as seen in the

picture above.
2.4 Components

Any component may be inserted by selecting it from the component drop-down menu on the
main tab. However, the site component or parking component may be used in the massing
and tab model site. The component button will allow to use of any item that is currently
present in the Revit project file to create a generic component. Site Component, on the other
hand, simply allows for the placement of site items such as plants and parking components.
When there are many different types of objects, it will be beneficial to filter them out using

different tools. As a result of placing the item as a site component, the site topography will be
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assigned as the object’s host automatically. Families may be found and loaded. Placing the
component should be a simple process. Users can simply activate the component tool, pick
the kind of component, and then click on the model to put it in the desired location. If the
required item is not accessible in the Revit project, it may be necessary to load a family of
objects. With the installation of Revit, several default families are included. There are also a
large number of Revit families available on the internet. To find the component, the user may
try utilizing Autodesk Seek. Placing Component. Open the users' tool, pick the component,

and drop it into position.
2.5 Roof

To create a roof using a footprint display, either a floor layout or a mirrored ceiling plan, go
to the Architecture tab, and create a roof drop-down panel (Roof by Footprint). If an attempt
is made to place a roof on the lowest level, a dialogue window will urge the user to move it to
a higher level. If it does not raise the roof to a higher level, Revit will warn users later that it
is too low. Select a drawing or a tool from the Draw panel. Before sketching, use the
Characteristics panel to change the properties of the roof. When using Pick Walls, it is
possible to specify the overhang before drawing the roof. If users want the overhang to be
measured from the wall's core, choose to “Extend” to the wall core on the Options Bar, and
then enter a value for Overhang. Draw or choose a closed loop for the roof by clicking on
“Defines Roof” Slope in the Properties panel after you've selected a line, users may change
its definition of slope. After that, users will be able to alter the slope's value. When slope
defining is selected, this symbol shows next to the roofline, after clicking, users will be taken
to a 3D view (Finish Edit Mode), then complete with an overhang on the gable Select the roof
first and then choose Sloped Glazing from the Type Selector. If the user wants to take
advantage of this feature it is possible to place drapery grids over the curtain panels of the
sloped glazing. The tab may be used to switch between the horizontal and vertical grids. The
roof in the drawing area may be selected and then chopped off to make room for another roof
to be sketched on top of it. The Cut-off Level and Cut-off Offset values are entered in the
Properties palette. This property shows the height above or below the eave's apex, depending
on the user's perspective. Make a new roof on top of the existing one and color it in. To create
a roof by extruding, show a perspective view, such as an elevation, 3D models, or cross-
section. Then navigate to the Architecture section by selecting it from the menu bar and
assemble a board drop-down hatch in the roof (Roof by Extrusion). Identify the working

surface. Select a value for Level in the Roof Reference Level and Offset dialogue. By default,

81



Fayyaz et al

the highest level of the project is chosen. To raise or lower the eaves from the reference level,
enter an Offset value. When an offset is provided in Revit, a reference plane is created at that
location. The extruded roof's location concerning a level is controlled by the reference plane.
Make an open loop out of the roof's profile. Then, click (Finish Edit Mode) to see the 3D
model in full glory. Make a Roof using Sketches and Extrusions It's possible to re-host or
modify the roof's work plane once it's been created using extrusion. To use sloped glazing,
choose the roof and then choose “Sloped Glazing” from the Type Selector. Sloped glazing
curtain panels may have curtain grids attached to them. To move between the horizontal and

vertical grids, press Tab on the user's keyboard.
2.6 Railing

The railing is such a component that its geometry will change if the host is modified. Users
choose a railing host by drawing handrails on the tops of floors, slabs, walls, and roofs.
Balusters and railings on non-stair hosts will follow the slopes and curves of irregular
surfaces when sketched. Select the kind of railing from the Type Selector menu. On the Tools
menu, choose Pick New Host. Choose the walkway floor from the available options. Use the
Draw tools to create a simple stair railing. To finish installing the railing, click Finish. Select
the host again, and then draw a railing on the other side of the path. The procedure is the
same whether you're painting the top of a wall or not. Select the kind of guardrail railing by
clicking Railing and then selecting it. To see the railing as it is being drawn, go to the Options
tab and choose Preview. Select the curved retaining wall by clicking on Pick New Host and
then on Curved Retaining Wall. Create a rough drawing of the railing's route using the Draw
tools and the Chain option. If required, offsets from the base level or sketched route may be
adjusted in the “Properties” panel. The positioning of the balusters and the railing's curve

match the host's geometry.
2.7 Room Tags

Tags may be assigned to rooms after they've been built if the Tag on Placement option wasn't
used while they were being built. It should be noted that users may tag all untagged rooms in
a view by using the Tag All Not Tag function. When rooms are placed and tagged in a floor
plan view, and tags are shown in a reflected ceiling plan (RCP) view, this feature comes in
handy. Activate the plan or section view by clicking on the appropriate button below. The
room & Area panel may be found by selecting Architecture from the Tools menu. The drop-

down menu for tagging rooms (Tag Room). Do the following in the Options Bar: Indicate the
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direction in which the room tag should be placed. Choose Leader if users want the room tag
to include a leader line. If a room tag has the leader enabled, it may be necessary to relocate
the room tag to view the leader. The leader's end will be kept in the marked chamber until the
game is over. To put a room tag, just click on the desired location inside the room. Room tags
are automatically aligned with those that have already been placed. If rooms overlap where
you click to put a tag just one room will be marked as a result. A room in the current model is
marked if it is shared by another room in the connected model and their boundaries overlap.
Users may make changes to a room tag's settings after they've placed it.

2.8 Insert Features

The Insert menu or tab in the Revit menu bar is a critical tab for Revit users because it
provides critical choices for connecting and managing linked files that are used in Revit. To
avoid conflicts between components that are developed into multiple Revit disciplines, such
as Revit Architecture, Revit Structure, and Revit MEP, connecting files is necessary. Files
may also be connected to verify the coordination of their components and to gather data
about the linked file's elements. To put it another way, Revit users always utilize the Insert
tab to connect a file in Revit. The Insert tab has many options. The first option Revit users see
when they select the Insert tab in the Revit Menu bar is 'Link Revit." Revit users may utilize
the Link Revit option to link an RVT file to their existing Revit project. To connect Revit
MEP to Revit structure, for example, users must first click the Insert tab and then choose the
Link Revit option from there. The 'Link CAD' option in the Insert tab may be used to link
CAD files into a Revit Model. Many times, Revit users must consult a CAD file for relevant
information while creating 3D models. The DWF Mark-up option is also included in the
Insert tab. To connect a DWF file to the current Revit project, choose this option from the
menu. To add an indexed point cloud file to Revit, users use the Insert tab's Point Cloud
option, which may be found on this page: To put it another way, users who wish to connect
an "RCP and RCS" files in Revit must utilize the Insert tab's Point cloud option. Finally, the
Insert tab has a Manage Links option, which is used to control and manage the files that are
connected to a Revit project host. To summarise, users will have access to many critical

choices for connecting files in Revit when they select the Insert tab.

2.9 Annotate

Annotation labels can serve as text placeholders in tags or title blocks. Users can create labels

for use with tags or title blocks in the Family Editor. Users may replace the label's text with
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whatever they like while creating a tag or title block, and it'll appear in the project alongside
the rest of the family. Under the File menu, choose “New Annotation” Symbol or Title Block.
Select the appropriate starter family from the drop-down menu. To access it, create a Text
panel in the Family Editor's Label, and select it from the Create tab. Choose the label format
in the Format Picker. In the Format tab, vertical and horizontal alignment settings to modify
the justification can be changed. Simply clicking in the drawing space will drop the tag there.
To mark the intersection of two reference planes in a generic model tag, for instance, position
the cursor there. The box to modify a label appears. The editor permits alterations to the label

parameters.

2.10 Dimensions

To get the distance between two points on a drawing, use a linear dimension. To add
annotations, use the Dimensions panel's Annotate tab (Linear). To find a reference point on
an element, place the cursor at the intersection of two references, such as the joint between
two walls, such as a wall. The reference point indicates whether or not the dimension may be
placed at that location. By hitting Tab, the user may navigate between intersecting reference
locations. To specify the source, click here. Click where the user wants the next reference
point to be located using the mouse. A dimension line emerges when the user moves the
pointer. The user has the option to choose as many references as they like in the future. Press
the Spacebar to align the measurement to the vertical or horizontal axis after choosing a
second reference point. To click, move mouse should be moved away from the last element
and click after reaching the final reference point. The measurement will be shown on the

screen.

2.11 Region

An annotation family can be filled using the Filled Region tool. Steps depend on the design
goal. One should select Filled Region on the Detail panel's Annotate tab's Region drop-down
menu. Select a boundary line style from the Line Styles drop-down in the Modify. Create a
Filled Region Boundary Tab Line Style window. Draw a rough map of the region in the
Draw window. Select Edit Type on the Properties menu and then Fill Pattern to fill the
region. The Properties panel's Subcategory attribute controls region line appearance. After
editing the drawing, click “Finish” Edit Mode. Text can be added to the left, right, above, or
below a persistent dimension value. Users can change dimensions in sketching. Edit

dimension values by double-clicking. A dimension text editor appears. Use Actual Value as a
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Dimension Value option. Now updating dimension values. Enter text in the Above, Below,

Prefix, and/or Suffix areas. Only fill out text fields. OK confirms.

2,12 Location

Select the Manage tab in the location of the project's control panel. It is now possible to
access the Location Weather and Site dialogue box. Alternatively, the Sun Settings dialogue
box may be used to reach this window. Select the Location option from the drop-down menu.
Select one of the options to define location from the drop-down menu: Internet Mapping
Service is a service that allows you to map out the Internet. When a user's computer is
connected to the Internet, this option shows an interactive map via the Google Maps TM
mapping service, which is available for free. When no other project location is provided, the
location is designated as "Default” and is set to the longitude and latitude of the major city
chosen by Revit Architecture as the user locale. Please keep in mind that, as its name
suggests, the Internet Mapping Service is completely dependent on a functioning Internet
connection to operate properly. Users may still define a project location using this technique
even when Internet connectivity is absent; however, the associated longitude and latitude for
the location will remain unset until after Internet service is restored. The default city list is
shown below. This function displays a list of significant cities from which you may choose a
place. Until the user specifies a different project location, the location is defined as Default>
and is set to the longitude and latitude of the main city provided by Revit Architecture for the
user's locale until the user specifies otherwise. There is no need for an Internet connection.
One of the following techniques may be used to provide the project's location: Internet

Mapping Service or Default City List To proceed, click OK.
2.13 Manage

The Manage tab provides access to project standards and other settings via several tools. On
this tab, the user will also discover the Design Options and Phasing tools, among other things.
Additional options, such as Review Warnings and Select By ID, may be found on the
Manage page and will aid in the smooth operation of the user's project as well. Object Styles,
which can be found on the Manage tab, is one of the most essential settings that you will
utilize throughout your project. By selecting this option, the user will be able to adjust the
global visibility settings for almost everything in the project, including how it projects, how it

cuts, and the color and pen weight associated with everything.
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2.14 Wall Detail

The common changes in wall function, composition, and thickness are reflected in the pre-set
system family types that are used for walls, just as they are for the other essential components
of a building model. For example, walls are a type of present system family. Users can
modify a wall in many ways, including its thickness, assigned material, number of layers, and
how they are broken up. To add walls in the building model, the user needs to click the Wall
tool, then select the desired wall type, and after that place instances of that type in the plan
view of the three-dimensional view of the model. To insert an instance, users must first select
a drawing tool from the ribbon, then either sketch the wall's linear extents in the drawing
area, or specify them by selecting a line, edge, or face from the library. “Location Line” is
one of the properties of a wall that controls where it will be placed about the path the user
creates. The location of the wall about the path drawn or the selected element is set by the
value of this instance attribute. After placing a wall in a design, users may customize it by
adding sweeps or reveals, editing the profile of the wall, and inserting hosted components
such as doors and windows. Users should know that after building walls, they may wish to
audit files so that Revit may examine data structures and fix any issues that are discovered
inside the model. To audit, a project file first opens the project and then chooses the Audit

option from the Open dialogue box.

The Location Line property of a wall defines which of the wall's vertical planes is used to
position the wall concerning the route user’s sketch or otherwise described in the drawing
area by specifying which of the wall's vertical planes is utilized. Using compound walls that
connect, users may precisely position them concerning a specific material layer of interest,
such as the concrete masonry units, while building up a compound wall. The following planes
may be selected, regardless of the wall type, either on the Options Bar (before putting the
wall) or on the Properties palette (before or after placing the wall): regardless of the wall type
the centreline of the wall (default) The centreline is at the heart of everything. The face of the
finish: exterior. The face of the finish inside. The face of the core: the outside. The face of the
core: the inside Specifically, the core of a wall refers to the primary structural layer or layers
of a wall in Revit language. In a simple brick wall, the Wall centreline and Core centreline
planes would coincide, while in a compound wall, the Wall centreline and Core centreline
planes would most likely vary. When users create a wall from left to right, the outside face

(Finish Face: Exterior) is automatically placed at the top of the wall by the program.
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2.15 Default 3D

All components of the building model are the same size independent of the camera's distance
in orthographic 3D views, which display the building model in a 3D perspective. To place the
camera in a target point, the user should select a plan, section, or elevation view from the
menu bar. Further, select the “View” tab from the drop-down menu. Create a panel with a 3D
View drop-down menu. Then, select the Manage tab. The views panel is a section of a
website that displays information about the views of other people. Select the Perspective
choice from the “Options Bar” and click “OK”. The camera should be placed by clicking
once in the drawing area, and the target point should be placed by clicking twice. If a user
wishes to define the projection mode in existing views, right-click the “View Cube” and
choose “Orthographic” from the context menu that appears. The Project Browser shows an
unnamed 3D version of the current project that was previously opened. If a view with no
name already exists in the project, the 3D tool opens the view that was previously closed. The
default 3D view may be renamed by right-clicking the view name in the Project Browser and
selecting Rename from the context menu. The project includes a copy of the named 3D
views. Once the default, the unnamed 3D view has been renamed, the following time the 3D
tool is invoked by the user, Revit launches a new nameless view by default. A section box
may be used to restrict the part of a 3D view that can be seen by the user. To position the
camera over the southeast corner of the model, select the View tab from the drop-down
menu. Create a panel with a 3D View drop-down menu. The default 3D view is shown. This
action positions the camera above the southeast corner of the model, with the target

positioned in the middle of the ground level, as seen in the image below.

Launch a plan view. Select the View tab, and make a panel Drop-down menu for elevation
(Elevation). The elevation symbol appears as the cursor. (Optional) Select a view type from
the list in the Type Selector, or click Edit Type to change an existing view type or create a
new view type. Place the elevation sign by moving the cursor near a wall and clicking. Users
may adjust the location of the arrowhead by pressing Tab while the pointer travels. The
arrowhead is designed to snap to perpendicular walls. Highlight the square shape of the
elevation sign and click to create various internal elevation views. The elevation symbol
appears with check box choices for generating views. Use the rotation control to align to
angled components in the plan. Select the checkboxes to indicate where you wish elevation

views to be created. To conceal the checkboxes, move your mouse away from the elevation
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symbol. To pick a symbol, highlight an arrowhead on it. To see the clip plane, click the

arrowhead once.

Clip planes' endpoints snap and connect to walls. The width of the elevation may be adjusted
by dragging the blue controls. If the blue controls are not visible in the view, pick the clip
plane and go to the Modify Views tab. Element Properties in the Element panel. Select the
Crop View option in the Instance Properties window and click OK. Select the new elevation
view in the Project Browser. Elevation views are identified by a letter and a number, such as

Elevation (1-a).
2.16 Section

To create a new section user can do this by adding a section line and cropping the area around
it. Open a plan, section, elevation, or detail view in the drawing program. Select the View tab
from the drop-down menu. A panel should be created (Section). If a user wishes to go across
the model or family, it can be done by starting from the section and dragging the mouse to the
end. If the datum or wall is not orthogonal, users may snap a section line parallel or
perpendicular to a non-orthogonal datum or wall. In plan views, the option of snapping to a
wall is offered. When users can conclude the section by pressing the Enter key. The section
line as well as the crop area are shown and may be chosen. Users may resize the crop area by
dragging the blue controls to the appropriate size. As a result, the depth of the section view is
adjusted appropriately. To leave the Section tool, click “Modify” or press “Esc”. The section
view may be accessed by double-clicking the section header or by selecting it from the
Sections grouping in the Project Browser. When the design changes or when the section line

is changed, the section view is updated accordingly.

In Section view properties each section contains type attributes for section tags, callout tags,
and reference labels, all of which are unique to that section. To customize the appearance of
section tags and callout tags, the user can go to the “Manage” tab “Settings” panel
“Additional Settings” drop-down (Callout Tags), or the Additional Settings drop-down
(Section Tags). When a section is designated as a reference section, the Reference Label
parameter specifies the text that will be shown next to the section bubble. It is pertinent to
note that users cannot change the Detail Number or Sheet Number attributes for a section.
When a section view is added to a sheet, the values for these fields are automatically filled in.
The navigation bar offers access to navigation tools such as the “View Cube” and the

“Steering Wheels”, among other things. The navigation bar appears in the drawing area,
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along with one of the sides of the current model's window, and may be moved about with the
mouse. By default, the navigation bar is shown on the screen. The navigation bar contains
tools that are relevant to the currently active 2D or 3D view. To access a tool, click on its
button in the navigation bar or choose it from the drop-down list at the bottom of the page. To
display or conceal the navigation bar, the user can choose or clear the Navigation Bar from
the View tab of the Windows panel User Interface drop-down menu. The navigation bar
provides access to the following tools for navigating the site. Model orientation is indicated
by this value, which may be used to realign the current view of the model. Orientation is
indicated by this value. Steering wheels are a kind of steering wheel. A collection of wheels
that allow for quick switching between different types of navigational instruments. Active
View may be panned. Users may move the active view around on a sheet by dragging the
pointer to pan the view around with their fingertips. This option is only accessible from a
sheet's active view if the sheet has been activated. For additional information, see Modify a
Sheet's View for more information (Zoom). Magnification tools are a collection of
navigational tools that allow you to magnify or reduce the current view of a model 3D mouse
is a mouse that has three dimensions. Using a 3D connexion 3D mouse, the user may reorient
and move across a model's perspective. This option is only accessible if a 3D connexion 3D

mouse has been installed on the computer system.
2.17 Material Apply

The Material Browser dialogue allows users to design new material. The most effective
approach is to make a copy of an existing piece of content and then make necessary changes
to the name and other characteristics. A machinery model, as an example, could include
many steel components that are dull grey. For chrome-plated surfaces, users may duplicate
the steel material and then replace the grey look with a chrome appearance to produce an
appropriate material while maintaining the physical asset's original appearance. A new
material may be created from scratch in the absence of an equivalent source of the material. If
users choose this route, they will have to do additional editing work like adding assets and
altering property values. To duplicate an existing substance to produce something new. To
access the Material Browser, the user can go to the Manage tab and choose Materials from
the Settings panel. Then, in the Material Browser, the user can choose the source material and
open it in the Material Editor panel by selecting one of the options below: Select the material
from the list of project materials if it's already in the current project. Otherwise, the user can

select the item from the list of library resources and then click Add - Edit at the right end of
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the material row. As a result, the content is now part of the whole project. Click the Duplicate
Selected Material drop-down option in the Material Browser dialog's browser toolbar at the
bottom. The new substance has the same name as the original, but an extra number is added
to the end of the name. The new material is added to the project's list of materials in the
Material Browser and may be seen in the Material Editor panel. The new material's name,
information, assets, and attributes may all be customized in the Material Editor panel. To
quickly access options for renaming, duplicating, and other common materials operations,
right-click on a material in the Material Browser project materials list. To start from scratch
and develop a new substance. Log in and click on the Material Browser's Settings panel.
Materials. Click on the browser toolbar in the Material Browser to bring up the menu for
clicking. Material Browser adds the material as Default New Material to the project's list of
materials. Replace the default material name with a descriptive one in the Material Editor
window, above the Assets list. To define a new material, enter more information, add assets,

and modify attributes as needed.
2.18 Railing

The ribbon's tabs and panels can be rearranged to meet the requirements of the user. Tabs
may be removed from the ribbon by clicking the Remove Tabs button. This process may only
be carried out by users who have been permitted by their BIM manager. To access the File
Options window, the user can go to the File menu and choose Options from the Check boxes
under Tools and Analyses on the User Interface tabs to conceal the ribbon from displaying
those tabs will be cleared. Users can change the order in which tabs appear on the ribbon, by
dragging the tab label with CTRL+D to the appropriate spot on the ribbon.

2.19 Copy, Move & Mirror

In Autodesk Revit, the users can flip any model element with the Mirror tool, by drawing a
line across it and utilizing it as the mirror axis. It depends on the user whether or not to use
the mirror's axis as the primary axis. Any element can be duplicated by using the Mirror tool.
Mirroring a wall across a reference plane, causes it to flip the other way. If the user wants to

mirror any component he/she can click either Mirror - Pick Axis or Modify Element Tab.

User has the option of selecting inserts like doors and windows without the costs associated
with them. The mirror axis line may be selected by selecting Pick Mirror Axis from the
toolbar. Alternatively, they may use the Draw Mirror Axis option to make a temporary mirror

axis line. Clearing Copy from the Options Bar will allow you to move the chosen object
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instead of creating a copy. To clear Copy from the Options Bar, use CTRL when users are in
the Edit mode. To create a mirror axis, choose or draw a line. Only a line or a plane may be
selected as a reference point for the cursor. Users can't reflect anything around avoid. Revit
repositions the chosen element in opposition to the specified axis and moves or copies it.

2.20 View Cost and Estimation

When evaluating different construction choices, Revit options may be utilized to compare
them side by side. Users may refine quantities and give them values for a fairly accurate

materials cost analysis by utilizing a realistic method based on real-world facts.
2.21 Schedule

Keys that automate the creation of new schedules may be added by users when a schedule is
built or modified. Users can see the current view, by going to the View tab and creating a
drop-down menu for Schedules/Quantities in the Schedules panel.

These are the steps the user should take to generate the section and callout details at Revit
view. The design aims of the end-users may be different. They may also import drawings and
utilize this technique. To make use of the view generation tool, the user can do one of the
following actions, go to the “View” tab and assemble a board (Callout). To see the current
view, go to the “View” tab, and assemble a board (Section). Select Detail View: Detail from
the Type Selector. Choose an acceptable detail scale in the Options Bar. Select Reference
Other View from the Reference panel's drop-down list to refer to another detail or drafting
view. To easily find the reference view name in a lengthy list of view names, put keywords in
the Search box. To specify where the section will be cut, choose two points in the plan view.
If users are using the callout view, be sure to select the region they want to appear in the
callout. Select Halftone from the Display Mode drop-down menu on the Properties panel, and
then click OK. Half-toning model elements in the callout view help users distinguish between

the basic model geometry and further details.

3 Results and Discussions

Autodesk Revit is corresponding better than Autodesk AutoCAD. The interface tab made
Revit more interesting and elaborated it as well. The 2D (floor plans, section, and elevation),
3D (modeling, renderings, and animation), and 4D (cost and estimation) are explained in
detail verbally and the use of figures makes it easier. To be compatible with other programs
such as Format, and Google Sketch-up, it uses DWG, DFX, and IFC format files.
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3.1 Details of Floor Plans

Architects, landscape architects, urban planners, and engineers sometimes use a drawing
called a site plan or plot plan to depict the current and desired state of a specific area.
Transportation and urban planning are just two of the many types of planning that can be

included in a comprehensive site plan.

The site plan of the multi-story building consists of streets on both sides and Main Road at
the front. A gathering area with dimensions (33°-0°’x36’-9°") and a beautiful pergola

including Mumty floor is also given as shown in Fig. 4.

Fig. 4. Site Plan Basement & Ground Floor

The total covered area of the floor is 4118.7 ft? as shown the Fig. 5. Basement means any area
of the building having its floor subgrade (below ground level) on all sides. There are two
Basement Floor plans for car parking having a covered area of 5498 ft2. It consists of a spiral
ramp with a ratio of 1:6 and a lobby for a staircase and elevator. In basement 01 & basement
02 maximum of 7 cars can be parked and a wide driveway is provided to in or out the cars.
Rectangular structural columns and a shear wall are provided to strengthen the structure of
the multi-story building. Clear height is (9'-6") and (0'-6") with slab thickness The Ground
floor plan of the multi-story building consists of a reception at the entrance and offices with
an attached bath. The front wall dimension of the ground floor is (33'-0") wide and the side
wall is (109'-2") long. The clear height of the ground floor plan is (10'-0") and (0'-6") is its

92



Fayyaz et al

slab thickness. The skill level of all the windows is (0'-6"). The total covered area of the floor
is 4118.7 ft>. The first-floor plan of the multi-story building consists of 4 residential
apartments having a living hall, a kitchenette, a laundry area, a balcony, and a separate bath.
Each apartment has separate access for bedrooms through a separate staircase and also a
combined lobby for Stair and Elevator. The clear height of the first-floor plan is (10-0") and
(0-6") is its slab thickness. The skill level of all the windows is (0'-6") and the skill level of
the kitchen window is (3'-0").
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Fig. 5. First-floor Plan 2nd-floor plan & Mumty floor

The second-floor plan of the multi-story building consists of 4 residential apartments having
2 bedrooms with an attached bath and balcony. Each apartment has separate access to the
lower floor through a separate staircase. The clear height of the second-floor plan is (10'-0")
and (0'-6") is its slab thickness. The sill level of all the windows is (0'-6") and the sill level of
the kitchen window is (3'-0"). The total covered area of the floor is 4118.7 SQFT. Third-floor
plan of the multi-story building consists of 4 residential apartments having a living hall, a
kitchenette, a laundry area, a balcony, and a separate bath. Each apartment has separate
access for bedrooms through a separate staircase and also a combined lobby for Stair and
Elevator. The clear height of the third-floor plan is (10'-0") and (0'-6") is its slab thickness.
The sill level of all the windows is (0'-6") and the sill level of the kitchen window is (3'-0").
The total covered area of the floor is 4118.7 SQFT. The fourth-floor plan of the multi-story
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building consists of 4 residential apartments having 2 bedrooms with an attached bath and
balcony. Each apartment has separate access to the lower floor through a separate staircase.
The clear height of the fourth-floor plan is (10'-0") and (0'-6") is its slab thickness. The sill
level of all the windows is (0'-6") and the sill level of the kitchen window is (3'-0"). The total
covered area of the floor is 4118.7 SQFT. The fifth-floor plan of the multi-story building
consists of 4 residential apartments having a living hall, a kitchenette, a laundry area, a
balcony, and a separate bath. Each apartment has separate access for bedrooms through a
separate staircase and also a combined lobby for Stair and Elevator. The clear height of the
fifth-floor plan is (10'-0") and (0'-6") is its slab thickness. The sill level of all the windows is
(0-6") and the sill level of the kitchen window is (3'-0"). The total covered area of the floor
is 4118.7 SQFT.

The sixth-floor plan of the multi-story building consists of 4 residential apartments having 2
bedrooms with an attached bath and balcony. Each apartment has separate access to the lower
floor through a separate staircase. The clear height of the sixth-floor plan is (10-0") and (0'-
6") is its slab thickness. The sill level of all the windows is (0'-6") and the sill level of the
kitchen window is (3'-0"). The total covered area of the floor is 4118.7 SQFT. Seventh-floor
plan of the multi-story building consists of a single residential apartment having 2 bedrooms
with an attached bath, a living hall, a kitchen with dining, and a balcony. This floor has also
an open gathering hall with a kitchen and BBQ shelf. A separate washroom area is also
available for both males and females. The clear height of the seventh-floor plan is (10'-0")
and (0'-6") is its slab thickness. The sill level of all the windows is (0'-6") and the sill level of
the Kkitchen window is (3'-0"). The total covered area of the floor is 2827.6 SQFT. The
Mumty floor plan of the multi-story building consists of a stair hall and a machine room. It
has a wide terrace floor. The clear height of the top floor plan is (7°-6’") and (0’-6’) is its
slab thickness. The total covered area of the floor is 295 SQFT.

3.2 Details of Floor Plans

Section AA of the multi-story building is cut along the Y-axis of the building. The ramp,
stairs, elevator, wall, door, and windows are cut out in this section. The Section at BB of the
multi-story building is cut along the X-axis of the building as shown in Fig. 6. Stairs,

elevators, walls, doors, and windows are cut out in this section.
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Fig. 6. Sections at AA & BB Locations in the Building
3.3 Elevation

The front elevation of a multi-story building is 33'-0" in width and 105'-0" in height. The
dimension of the Left elevation of a multi-story building is 105-0" in length and 33'-0" in
width. There are a total of seven stories and a top floor or musty floor the dimensions of the
The right elevation of a multi-story building is 105'-0" in length and 33'-0" in width. There is
a total of seven stories and a top floor or musty floor as shown in Fig. 7. The details of each
story have been shown which shows the efficiency of Revit.
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Fig. 7. Front, Left, and Right Elevations

3.4 3D Modeling

The Revit software platform has become a popular option for designing and modeling
buildings and their components in 3D. The Building Information Modeling (BIM) 3D
modeling technique was brought into the Building sector to make the sharing of information
in 3D models easier. When compared to the prior practice, the project delivery system and

communication among all stakeholders have become more efficient as shown in the Fig. 8.
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Fig. 8. 3D Modeling

3.5 Rendering using Lumion

With the help of Lumion 8.5 some of the renders of the multi-storey building are shown in
Figs. 9-12. It can be seen that the render quality of Lumion is comparable with the Revit
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Fig. 11. Custom Elevation Render View in Lumion | Fig. 12. Custom Elevation Render View in Lumion

3.6 4D Scheduling

A schedule is a tabular display of information, extracted from the properties of the elements
in a project. A schedule can list every instance of the type of element you are scheduling, or it
can collapse multiple instances into a single row, based on the schedule's grouping criteria.
There are 127 Windows and 21 Ventilation on all floors of the multi-story building. The total
cost for these openings is Rs. 2014875/-, and 105 are the number of total doors and its cost is

Rs. 1727250/-. The doors and windows schedule the multi-story building.

4  Conclusions and Recommendations

In this project, Revit Architecture is selected for the preparation of Architectural drawings of
the multi-story apartment building. The complete 2D (floor plans, sections, and elevations),
3D modeling, and 4D (cost and estimation) are included in one Revit project file. Drawings
of a multi-story building in 2d with the detail of floors, section of the plan in horizontal and

vertical directions, 3D with renders, and estimation of the openings are completed. It quickly
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produces design alternatives. It is much more powerful and managing changes is much
simpler than AutoCAD. In AutoCAD, design engineers may have to update several files if
there is a change. Comparatively, Autodesk Revit is a time-saving software and can detect
human error easily. It is concluded Autodesk Revit Architecture is a great tool for complex
projects in terms of 2D architectural drawings, creating realistic 3D visualized models, and

Scheduling of the openings and it also supports multidiscipline design collaboration.

5 Recommendations

It is recommended for engineers that users operate the 2D drawings, MEP drawings,
Structural analysis, 3D (modeling, realistic renders, and animation), and 4D (cost and
estimation) of the whole project Autodesk Revit Architecture for the speedy and accurate
completion of the Project. Autodesk Revit Architecture is helpful for 5D (project

management) and also preparation of the pre-construction documentation.
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